WARP Project Forums - Wireless Open-Access Research Platform

You are not logged in.

#1 2018-Jan-11 06:20:01

ritwayk
Member
Registered: 2018-Jan-09
Posts: 2

Unable to generate pcore from simple_streaming

Hello,

I've just started to use the WARPv3 board and I'm trying out the simple_streaming design from the WARP_Repository. Has anyone generated a pcore/bitstream from the simulink design and managed to get it working on the board?

I have been getting a lot of errors while trying and have finally arrived at an error that I cannot solve.

Begin generation
Checking model status
Checking simulation times
Performing compilation and generation

*** ERROR ***

Errors occurred during netlist generation.
'<a href="matlab:open_and_hilite_hyperlink ('simple_streaming_txrx/Receiver/AGC Hook/Fine/Subsystem/Constant1','error')">simple_streaming_txrx/Receiver/AGC Hook/Fine/Subsystem/Constant1</a>' has an invalid constant (inf) sample time. Discrete states, continuous states, and tunable parameters are not allowed with constant sample times.

Offline

 

#2 2018-Jan-11 09:51:06

chunter
Administrator
From: Mango Communications
Registered: 2006-Aug-24
Posts: 1184

Re: Unable to generate pcore from simple_streaming

Does the design simulate in System Generator without error? If there is an error there, you'll have to fix it before exporting. The design definitely worked at the time it was created with the Xilinx ISE v10 tools with Service Pack 2. If you want to use the design as-is, you'll have to install old tools. Otherwise, you'll have to update the design to use the v14.4 tools we use for WARPv3 releases of the 802.11 Reference Design and WARPLab.

Offline

 

#3 2018-Jan-13 00:11:03

ritwayk
Member
Registered: 2018-Jan-09
Posts: 2

Re: Unable to generate pcore from simple_streaming

The design does not simulate in Sysgen, it gives errors. Simulink does ask to update blocks and even after trying that, it gives this error. Any other way to get it working without installing older tools?

Offline

 

#4 2018-Jan-13 16:47:07

murphpo
Administrator
From: Mango Communications
Registered: 2006-Jul-03
Posts: 4964

Re: Unable to generate pcore from simple_streaming

What are the errors? We can't provide much guidance without more details of the problem

Offline

 

Board footer