WARP Project Forums - Wireless Open-Access Research Platform

You are not logged in.

#1 2019-Dec-05 02:30:22

lpeng
Member
Registered: 2019-Dec-05
Posts: 3

"wlan_phy_tx_pmd" (Mango802.11Ref) Error by simulation and generation

Hi,

I am starter with "Mango802.11Ref. v1.8.0" for research purpose and will do study experiments on WARP v3 HW nodes.

As I try to generate or simulate the "wlan_phy_tx_pmd" mdl. I am going to export them later to EDK pcore.   I got following errors from simulink.

Error in 'wlan_phy_tx_pmd/Radio Controller & MAC IO/Delay': This proxy block was inserted in the model because a block of type 'Delay' could not be located during model load. Updating or simulating a model containing such a proxy block is not permitted

/* Info about SW Env */
Xilinx ISE 14.4
Matlab 2011a
Win7 64b

BTW. I can sucessfully generate bitstream and flash (using the EDK_Reference and XPS_SW Reference) on WARP v3 HW.

Could you give me some hint about the error ?
1) is that error caused due to the older version "Matlab" ?
2) or is it possible to replace with other blocks ? Our university seems only having the license of Matlab 2011a.

with best regards,
Leqiao

Last edited by lpeng (2019-Dec-06 00:05:21)

Offline

 

#2 2019-Dec-05 06:51:01

lpeng
Member
Registered: 2019-Dec-05
Posts: 3

Re: "wlan_phy_tx_pmd" (Mango802.11Ref) Error by simulation and generation

I have tried following fixes in the Simulink module "wlan_phy_tx_pmd" to avoid errors by pcore generation.

1) remove "Delay" and "Delay2" from "I/O Control" group. These Delay blocks seem only to do for Simulation. So they may be irrelevant with HW generation.

2) repair the wire connection in "EDK Processor" to AXI_ARESETN port.

Offline

 

#3 2019-Dec-05 10:45:31

murphpo
Administrator
From: Mango Communications
Registered: 2006-Jul-03
Posts: 5137

Re: "wlan_phy_tx_pmd" (Mango802.11Ref) Error by simulation and generation

Error in 'wlan_phy_tx_pmd/Radio Controller & MAC IO/Delay': This proxy block was inserted in the model because a block of type 'Delay' could not be located during model load. Updating or simulating a model containing such a proxy block is not permitted

I've never seen this error in many years of using Sysgen/Simulink. My best guess is that we saved the model in MATLAR 2011b, and somehow the older 2011a version of Simulink didn't understand the 'Delay' block.

You're correct that those Delay blocks (the Simulink Delay blocks, not the Sysgen Delay blocks) are only used in simulation and can be removed without breaking the FPGA core.

2) repair the wire connection in "EDK Processor" to AXI_ARESETN port.

This is also unusual - the block diagram inside the EDK Processor is automatically generated - I've never needed to modify it directly. If this worked for you, great. Otherwise I would suggest noting the configuration options of the EDK Processor block, deleting it, then adding a new one from the Sysgen library. This should force Sysgen to regenerate the AXI interface block diagram.

Offline

 

#4 2019-Dec-06 00:03:45

lpeng
Member
Registered: 2019-Dec-05
Posts: 3

Re: "wlan_phy_tx_pmd" (Mango802.11Ref) Error by simulation and generation

Thanks much for reply.

regard to this issue,  I try with newly unzipped "Mango802.11Ref" (still using Matlab 2011a, ISE 14.4).

2) repair the wire connection in "EDK Processor" to AXI_ARESETN port.

After simply removing "Delay" and "Delay2" blocks, the pcore-generation can be completed well. 

There is no "AXI_ARESETTN connection" issue as before. 

Last time I did click something on "EDK Processor Block" etc, as result some port connections of AXI become unconnected.

with best regards,
Leqiao

Last edited by lpeng (2019-Dec-06 00:05:05)

Offline

 

Board footer